martes, 18 de agosto de 2009

Verificación de Compatibilidad de Aplicaciones para el Snow Leopard

Ya falta poco tiempo para la salida al mercado del Mac OS X Snow Leopard en Setiembre, (incluso se rumorea que podría salir este mes) y acabo de ver en la página de TUAW un muy buen tip que nos servirá a todos los que estemos pensando en actualizar nuestro sistema.

Ahora, hagamos un pequeño recuento para poder entender acerca de lo que explicaremos a continuación.

Cuando Snow Leopard salga al mercado, Apple habrá dejado de lado definitivamente a las Mac con procesadores Power PC ya que esta última versión del Mac OS X sólo será compatible con Macs con procesadores Intel. Ahora con Leopard, las Mac utilizan Rosetta, un traductor dinámico que hace posible que cualquier Mac con procesador Intel, pueda correr aplicaciones (aunque de una manera mucho más lenta) hechas para Macs con procesadores Power PC (las antiguas), sin embargo con Snow Leopard Rosetta será una instalación opcional.

Así que para evitar sorpresas el día que instalen su flamante sistema nuevo, pueden desde ahora verificar que sus aplicaciones sean compatibles con Snow Leopard. Para hacerlo sigan éstos pasos:
  • Abran su folder de Aplicaciones y coloquen el cursor en la primera aplicación de la lista.
  • Luego presionen Opción-Command-I , lo cual activará un menú de información que mostrará los datos de cualquier aplicación que elijan, así sólo tendrán que bajar con el cursor para ir viendo los datos de cada una sin tener que abrir la ventana de información cada vez.
  • En la ventana información, bajo el apartado "General" busquen la palabra "Tipo" (o Kind en inglés) y verifiquen para qu[e plataforma es que la aplicación está desarrollada.
Si dice "Universal" o "Intel" no hay problema, pero si dice "Power PC", esa aplicación NO correrá con el Snow Leopard, por lo que deberán evaluar si es que la borran o si al momento de instalar el Snow Leopard eligen instalar nuevamente Rosetta (que puede ocupar bastante espacio).

Casi todas las aplicaciones que encuentren que sean Power PC deberían de contar con versiones Intel en las páginas de donde se les descargaron, pero habrá algunas que no, y que deberán ser borradas si se desea actualizar el sistema. La más conocida de éstas es Microsoft Office for Mac 2004 que no cuenta con una versión Intel, así que quienes deseen actualizar al Snow Leopard deberán adquirir Microsoft Office 2008.Así que ya saben, es mejor ponerse a depurar aplicaciones y a actulizar las antiguas ahora para no dejarlo a última hora y darse con la sorpresa que alguna aplicación favorita ya no funciona.